Page 1 of 1

Undefined symbol mpi_fortran_errcodes_ignore__

Posted: Wed Nov 04, 2015 11:00 am
by MBaeker
I am using Ubuntu 14.04 with openmpi, following this guide ... on-ubuntu/

It worked before, but after re-installing my machine and re-compiling vasp (without errors), I get the following error when I try to run vasp:
vasp: symbol lookup error: /usr/lib/ undefined symbol: mpi_fortran_errcodes_ignore__

Strangely, the symbol seems to be actually there:

> readelf -W -s /usr/lib/ | grep "errcodes_ignore"
16: 0000000000000000 0 OBJECT GLOBAL DEFAULT UND mpi_fortran_errcodes_ignore__
142: 0000000000000000 0 OBJECT GLOBAL DEFAULT UND mpi_fortran_errcodes_ignore
244: 0000000000000000 0 OBJECT GLOBAL DEFAULT UND mpi_fortran_errcodes_ignore_

I suspect that this may be due to the symbol being only in the static part of the library, for when I run
readelf -W -s -D /usr/lib/ | grep "errcodes_ignore"
I don't get any result, but I'm a bit clueless on how whether this really is the problem and how to solve this.

Any help would be appreciated,

Re: Undefined symbol mpi_fortran_errcodes_ignore__

Posted: Fri Nov 13, 2015 4:21 pm
by MBaeker
I actually solved this with the help of this question: ... ed-library

My LD_LIBRARY_PATH contained a path to a different version of MPI (used for another software I am using). Changing the path before running the program resolved the issue.