problem when compiling VASP 6.2.0

Questions regarding the compilation of VASP on various platforms: hardware, compilers and libraries, etc.

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
jcconesa
Newbie
Newbie
Posts: 32
Joined: Mon Jul 03, 2006 10:48 am
Location: Madrid

problem when compiling VASP 6.2.0

#1 Post by jcconesa » Tue Mar 16, 2021 10:47 am

I tried to compile VASP.2.0 in a parallel computer. The module list includes
intel/icc/15.0.1.133
intel/ifort/15.0.1.133
intel/mkl/11.2.1.133
compiler/intel_XE_2015_u1
intel/impi/5.0.2.044
mpi/impi-5.0.2.044

After indicating building of a few libraries, I find the following errors:

Code: Select all

main.F(274): error #6463: This is not a derived type name.   [PRIM_CELL_T]
      TYPE (prim_cell_t) PRIM_CELL
------------^
main.F(1004): error #6404: This name does not have a type, and must have an explicit type.   [PRIM_CELL]
      PRIM_CELL = PRIM_CELL_T(LATT_CUR, DYN%POSION, SYMM)
------^
main.F(1004): error #8212: Omitted field is not initialized. Field initialization missing:   [SUPER_LATT]
      PRIM_CELL = PRIM_CELL_T(LATT_CUR, DYN%POSION, SYMM)
------------------------------^
compilation aborted for main.f90 (code 1)
make[2]: *** [main.o] Error 1
cp: cannot stat ‘vasp’: No such file or directory
make[1]: *** [all] Error 1
make: *** [std] Error 2
Nothing appears in directory bin. Which may be the reason?
José C. Conesa

merzuk.kaltak
Administrator
Administrator
Posts: 123
Joined: Mon Sep 24, 2018 9:39 am

Re: problem when compiling VASP 6.2.0

#2 Post by merzuk.kaltak » Tue Mar 16, 2021 11:28 am

Dear José,
The Intel-Compiler suite 2015 is not supported,
please use a more recent ifort version or any other supported toolchain.

jcconesa
Newbie
Newbie
Posts: 32
Joined: Mon Jul 03, 2006 10:48 am
Location: Madrid

Re: problem when compiling VASP 6.2.0

#3 Post by jcconesa » Tue Mar 23, 2021 9:54 am

Dear Merzuk,
using a module list that includes

intel/icc/19.0.5.281
intel/ifort/19.0.5.281
intel/mkl/2019.0.5.281
compiler/intel_parallel_studio_xe_2019_u5
intel/impi/2019.0.1.144
mpi/impi-2019.0.1.144

Things seem to work OK. Thanks
José C. Conesa

Post Reply