vasp 5.4.1 seg faults

Questions regarding the compilation of VASP on various platforms: hardware, compilers and libraries, etc.

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
steven_lee1
Newbie
Newbie
Posts: 1
Joined: Tue Feb 23, 2021 2:28 pm
License Nr.: 5-207

vasp 5.4.1 seg faults

#1 Post by steven_lee1 » Thu Apr 01, 2021 3:30 pm

Hi,

I am moving a VASP 5.4.1 installation from an old cluster installation (CentOS 6 with Intel 16 toolchain) to a new installation (CentOS 8 with the newest Intel OneAPI HPC kit). I am using the same makefile.include file with a minor change to reflect the different location of MKL. But the code that used to run on the old cluster seg faults on the new cluster. Can you give me some pointers on how to debug this problem? I've attached the relevant environment variables, makefile.include file that was used to build VASP 5.4.1 on the new cluster, and the error message produced by the seg fault. Thanks.


Steven
You do not have the required permissions to view the files attached to this post.

ferenc_karsai
Global Moderator
Global Moderator
Posts: 126
Joined: Mon Nov 04, 2019 12:44 pm

Re: vasp 5.4.1 seg faults

#2 Post by ferenc_karsai » Thu Apr 08, 2021 3:48 pm

That is a very old VASP version, so we are not really giving support for that anymore.

Hard to say what it could be with that little information, but most likely a problem in one of the parts of the toolchain. Especially if it worked on another cluster.

You could try -traceback (also -debug and -g) to see where it crashes.

Post Reply