VASP 6.2.1 Installation on Ubuntu 20.04.2 LTS - Tests failed

Questions regarding the compilation of VASP on various platforms: hardware, compilers and libraries, etc.

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
chempu
Newbie
Newbie
Posts: 2
Joined: Wed Jun 09, 2021 1:26 pm

VASP 6.2.1 Installation on Ubuntu 20.04.2 LTS - Tests failed

#1 Post by chempu » Tue Aug 24, 2021 7:15 am

I successfully compiled VASP 6.2.1 on Ubuntu 20.04.2 LTS following the link "wiki/index.php/A_Ubuntu_based_installation_of_VASP" and have obtained all the three exe files (std, gam, ncl) in the ./vasp.6.2.1/bin folder. However the tests failed, see the attached files (makefile and testsuite.log) for reference. The system is Intel based with 32 GB memory. Please advice.
You do not have the required permissions to view the files attached to this post.

ferenc_karsai
Global Moderator
Global Moderator
Posts: 128
Joined: Mon Nov 04, 2019 12:44 pm

Re: VASP 6.2.1 Installation on Ubuntu 20.04.2 LTS - Tests failed

#2 Post by ferenc_karsai » Tue Aug 24, 2021 11:50 am

I just checked your outputfile and all calculations show the following:
"mpirun has detected an attempt to run as root.

Running as root is *strongly* discouraged as any mistake (e.g., in
defining TMPDIR) or bug can result in catastrophic damage to the OS
file system, leaving your system in an unusable state.

We strongly suggest that you run mpirun as a non-root user.

You can override this protection by adding the --allow-run-as-root option
to the cmd line or by setting two environment variables in the following way:
the variable OMPI_ALLOW_RUN_AS_ROOT=1 to indicate the desire to override this
protection, and OMPI_ALLOW_RUN_AS_ROOT_CONFIRM=1 to confirm the choice and
add one more layer of certainty that you want to do so.
We reiterate our advice against doing so - please proceed at your own risk."

MPI kills the calculation after this warning and the rest is follow up errors since the output files are missing for post-processing in the testsuite.

It seems you are running as a root. If you really need to run as root, follow the suggestions by the mpi warning.
Otherwise don't run as root, since it is generally better to run mpirun as a non-root user.

chempu
Newbie
Newbie
Posts: 2
Joined: Wed Jun 09, 2021 1:26 pm

Re: VASP 6.2.1 Installation on Ubuntu 20.04.2 LTS - Tests failed

#3 Post by chempu » Tue Aug 24, 2021 1:06 pm

I did try as a normal user as well, but got the following error:

csi@csi:/usr/bin/vasp.6.2.1/testsuite$ make test
if [ -f tools/compare_numbertable_new ] ; then \
rm tools/compare_numbertable_new ; fi
if [ -f tools/m_strings.mod ] ; then \
rm tools/m_strings.mod ; fi
cd tools ; mpif90 -o compare_numbertable_new compare_numbertable_new.f90
compare_numbertable_new.f90:190:20:

190 | end module m_strings
| 1
Fatal Error: Cannot open module file ‘m_strings.mod0’ for writing at (1): Permission denied
compilation terminated.
make: *** [makefile:9: numbertable] Error 1

ferenc_karsai
Global Moderator
Global Moderator
Posts: 128
Joined: Mon Nov 04, 2019 12:44 pm

Re: VASP 6.2.1 Installation on Ubuntu 20.04.2 LTS - Tests failed

#4 Post by ferenc_karsai » Thu Aug 26, 2021 6:25 am

This numbertable executable is not part of VASP. It's a small fortran program for numerical comparison that is compiled when executing the testsuite.

Ok there is two things:
1) You need to check if VASP runs at all. Please just try any simple VASP calculation and see if it properly starts and finishes.
2) From the last error message you sent, it seems again that you have permission problems, since the numbertable object during compilation cannot be accessed.

Post Reply