number of cells and number of vectors did not agree???

Problems running VASP, runtime errors, technical questions.
Please check whether the answer to your question is given in
the VASP online manual or has been discussed in this forum
previously!

Moderators: Global Moderator, Moderator

Locked
Message
Author
wjfriend
Newbie
Newbie
Posts: 7
Joined: Mon Jan 17, 2011 4:55 am

number of cells and number of vectors did not agree???

#1 Post by wjfriend » Sun Sep 25, 2011 5:45 am

I got the following error informaiton for my calculaiton. I tried to change the SYMPREC to 1e-8, but the error still exists. Can anyone give me some suggestions. Thanks.

VERY BAD NEWS! internal error in subroutine PRICEL (probably precision problem, try to change SYMPREC in INCAR ?):
Sorry, number of cells and number of vectors did not agree. 2
Last edited by wjfriend on Sun Sep 25, 2011 5:45 am, edited 1 time in total.

admin
Administrator
Administrator
Posts: 2921
Joined: Tue Aug 03, 2004 8:18 am
License Nr.: 458

number of cells and number of vectors did not agree???

#2 Post by admin » Wed Oct 05, 2011 4:23 pm

This problem appears with supecells and high symmetry atomic positions. Because of symmetry elements PRICEL cannot recognize the cell as a primitive cell.What helps is a slight move of atoms in high symmetry positions. E.g. move atom (0.0 0.0 0.0) to 0.0 0.0 0.0001. This breaks the symmetry and the cell is recognized as the primitive cell.
Last edited by admin on Wed Oct 05, 2011 4:23 pm, edited 1 time in total.

hess8
Newbie
Newbie
Posts: 18
Joined: Fri Jan 08, 2010 3:05 pm
License Nr.: 1022
Location: Utah, USA

number of cells and number of vectors did not agree???

#3 Post by hess8 » Mon Oct 17, 2011 8:54 pm

Thanks, I had the same error and your solution worked. You should put that advice in the error message itself :)
Last edited by hess8 on Mon Oct 17, 2011 8:54 pm, edited 1 time in total.
Bret

Locked