Page 1 of 1


Posted: Thu Jul 20, 2006 7:47 pm
by fabella
I started a job to relax the experimental structure of a crystal, and the job quit after two ionic steps with the error message:

ERROR FEXCP: supplied Exchange-correletion table is too small, maximal index : 4370

I read an existing thread concerning the same error message, but I don't think it can help me solve my problem because:

-As far as I know, I am using the latest version of vasp (4.6.28).
-My POSCAR file is the experimental structure, and thus it should be a reasonable input geometry.
-My INCAR file contains the line IBRION = 1.

Thanks for reading this and, hopefully, helping me out!


Posted: Fri Jul 21, 2006 7:57 am
by admin
please have a look at the actual geometry (XDATCAR), of that step: if the first ionic step was not fully converged electronically (please check), the calculated forces and the stress tensors may be completely wrong. If (in addition) POTIM is chosen too large, the following geometries may be unreasonable, though you started with a good guess for the first ionic step..


Posted: Mon Jul 24, 2006 3:00 pm
by The Evasperator
I looked at the geometry from the CONTCAR file, which I believe contains the coordinates of the last step in the relaxation. The structure is very different from the POSCAR with the experimental structure. However, the last successful ionic step was converged electronically.

I would guess that this radical change in structure would be due to a large POTIM value, but I am using the default value, POTIM = 0.5. Since the guess for the initial structure should be excellent, is it reasonable to reduce the POTIM value?

(Note: The user "fabella" submitted the thread above for me due to a momentarily forgotten password.)


Posted: Mon Jul 24, 2006 5:14 pm
by tjf
You haven't done something simple like use Cartesian coordinates with the fractional coordinates flag in CONTCAR, have you? You probably should check the output file to make sure that the structure Vasp sees is the structure you think it's seeing.

Otherwise, the forces being calculated must be big. Which shouldn't happen for the experimental structure. Please check that.


Posted: Mon Jul 24, 2006 10:34 pm
by The Evasperator
I looked at the OUTCAR file and it stated that the coordinates were direct, but the POSCAR had Cartesian written on the appropriate line. However, there were several spaces between the beginning of that line and C, the first letter of Cartesian. So, I think you may be right about my simple mistake.

I am waiting for the results of the calculation with "Cartesian" starting at the beginning of the appropiate line. Thanks for the suggestions, and I will follow up with a reply about the results.


Posted: Tue Jul 25, 2006 3:17 pm
by The Evasperator
That was the problem. Thanks!


Posted: Fri Jan 13, 2017 10:02 pm
by suxinghu
When I used pure Coulomb potential for Carbon simulations, I saw the similar error message: "ERROR FEXCP: supplied Exchange-correletion table is too small"

My solution is:

in the file of "xclib.F" change the line "!#define hugeXCtable" to "#define hugeXCtable", which solved my problem.


Posted: Fri Feb 12, 2021 5:58 pm
by henrique_miranda
In principle, uncommenting the line "!#define hugeXCtable" in xclib.F, as mentioned above, should not be necessary.
Use this only as a last resort.

The same issue was reported on a different thread:

In this case increasing the cutoff fixed the issue.