VASP crashes with intel mpi for more than 1 node

Questions regarding compilation of VASP on various platforms.

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
Wasabi
Newbie
Newbie
Posts: 3
Joined: Tue Jan 04, 2011 4:12 pm

VASP crashes with intel mpi for more than 1 node

#1 Post by Wasabi » Thu Jun 06, 2013 5:00 pm

Dear VASP Forum,


I'm trying to use vasp.5.3.3.

I compiled using intel MPI (IMPI) and MKL without any problems. Here are some important lines from my Makefile:

Code: Select all

??
FC=mpiifort??
FFLAGS?=??-FR?-names?lowercase?-assume?byterecl

OFLAG=-O2?-ip?-xHost

BLAS=?-Wl,--start-group?$(MKL_PATH)/libmkl_intel_lp64.a?$(MKL_PATH)
/libmkl_sequential.a?$(MKL_PATH)/libmkl_core.a??-Wl,--end-group?-liomp5?-lpthread?-lm

LAPACK=?$(MKL_PATH)/libmkl_intel_lp64.a


Our machine is a Linux cluster with 16 cores per node. Running up to 16 cores (1 node) we do not experience any problems.

Running on more than 16 cores with a simple (60 metal atoms) test systems seems to be perfectly smooth.

However, when I go to a larger system (~200 atoms) I get this error when I use more than one node:

Code: Select all

Fatal?error?in?PMPI_Alltoall:?Pending?request?(no?error),?error?stack:
PMPI_Alltoall(990)......:?MPI_Alltoall(sbuf=0xadc2b20,?scount=226,?MPI_DOUBLE_PRECISION,?rbuf=0xa805b00,?rcount=226,?MPI_DOUBLE_PRECISION,?comm=0x84000005)?failed
MPIR_Alltoall_impl(800).:?
MPIR_Alltoall(761)......:?
MPIR_Alltoall_intra(567):?



Do you recognize this error, what could be the reason for it?
If it helps, I can add the "traceback" option for the compilation ...


I have "ulimit -s unlimited" in my submission script ...

Also worth mentioning: Using more than 1 node I always get this error:

Code: Select all

[
forrtl: File exists
forrtl: severe (10): cannot overwrite existing file, unit 12, file /home/.../WAVECAR
/code] 

Of course I can circumvent this issue with "touch WAVECAR" and "touch CHGCAR" in my submission script. But maybe it is related to my problems?

ANY help is very much appreciated.

w.
Last edited by Wasabi on Thu Jun 06, 2013 5:00 pm, edited 1 time in total.

admin
Administrator
Administrator
Posts: 2921
Joined: Tue Aug 03, 2004 8:18 am
License Nr.: 458

VASP crashes with intel mpi for more than 1 node

#2 Post by admin » Wed Jun 12, 2013 4:52 pm

This error seems to be an bug in the MPI installation, please (MPIR_Alltoall), please ask your sys admin to check it
Last edited by admin on Wed Jun 12, 2013 4:52 pm, edited 1 time in total.

Post Reply