RPA calculation memory problem

Problems running VASP, runtime errors, technical questions.
Please check whether the answer to your question is given in
the VASP online manual or has been discussed in this forum

Moderators: Global Moderator, Moderator

Post Reply
Posts: 1
Joined: Sun Apr 15, 2018 7:44 pm
License Nr.: 5.4.4

RPA calculation memory problem

#1 Post by Yohannes » Tue Apr 17, 2018 12:29 pm

Dear forum users,

I was recently trying to use RPA method for metallic clusters using vasp 5.4.4 but could not be successful because of memory related problem. My computing severer has maximum of 64gb memory in one processor. I tried the the RPA calculation with both single processor and multiprocessors but at the third step (exact diagonalization of the Hamiltonian) get the same error message "forrtl: severe (41): insufficient virtual memory". I did the calculation procedurally according to the manual instruction for ACFDT/RPA. I took the NBANDS equal to number of maximum plane waves which is taken from the first step. My calculation employs only one k-point (gamma point).
With the same INCAR settings it works for small box size, for example vacuum=4 but does not work for vacuum spacing greater than 5.
Has anyone experience on this issues? I would appreciate any suggestions on this respect?
Thank you in advace!

best regards,

Posts: 2921
Joined: Tue Aug 03, 2004 8:18 am
License Nr.: 458

Re: RPA calculation memory problem

#2 Post by admin » Wed Jul 18, 2018 10:34 am

if you have a memory problem, it only helps to
1) increase the number of parallel nodes
2) choose the input parameters such that less memory is afforded:
this can be done by
reducing the basis set size: smaller cell, lower precision (ENCUT), less k-points

Post Reply